Problem installing converter, requests old version of .NET.

Jan 23, 2012 at 4:02 AM

'Arduino to Visual Studio' looks like an interesting tool but I keep getting the following error when I try to install it:

This setup requires the .NET framework version 2.0....

However, I have .NET framework 4.0 installed which should satisfy the requirement.

I haven't done any windows C++ dev since MFC so I'm rather ignorant of the .NET framework and its app packaging tools but I did notice a reference to .NET v2 with 'allow later versions = false in Setup1.vdproj:
   "Deployable"
   {
       "CustomAction"
       {
       }
       "DefaultFeature"
       {
       "Name" = "8:DefaultFeature"
       "Title" = "8:"
       "Description" = "8:"
       }
       "ExternalPersistence"
       {
           "LaunchCondition"
           {
               "{A06ECF26-33A3-4562-8140-9B0E340D4F24}:_92CC5E20A5FB47CBAADC7CF86194667F"
               {
               "Name" = "8:.NET Framework"
               "Message" = "8:[VSDNETMSG]"
               "FrameworkVersion" = "8:.NETFramework,Version=v2.0"
               "AllowLaterVersions" = "11:FALSE"
               "InstallUrl" = "8:http://go.microsoft.com/fwlink/?LinkId=131000"
               }
           }
       }

Could this be the source of my problems?